[bug] fail when adding food to a recipe

What just happened was weird, and it happened too fast to get a screenshot. It happened before but it was right before a release so I didn't report it.

I was entering a recipe. (As always, our wanted to call the recipe "Dinner" and include a timestamp even though it was a recipe, but that's already been established, right?)

So I tapped okay or save or whatever on the ingredient, and, hmm. Something weird happened to the screen (so sorry, I know vague bug reports suck. it was so fast!) and then it existed to the list of recipes and my recipe was gone.

As I mentioned, it's happened twice. I will watch for it and try to snag more details if it happens again.

Answers

  • Hmm. I just went back to the app, pressed back again from the list of recipes, and I was back in my unfinished recipe.

    I'll keep watching.

  • I'm not sure I totally follow, but I think I may have run into something similar at one point too, but also couldn't quite figure out what happened. I will look into it closer and try to reproduce, but if you can get more details as well that would be fantastic!

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • I think I got it @AnotherAlex . When you go to an existing recipe and edit the serving size of an existing ingredient within the recipe, is this when it fails?

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • I think so. I also think it might be connected with this other thing where the app freezes for a long time when editing food. This screen hung for something like 15-30 seconds? (That's been happening a bunch.)


  • @AnotherAlex which build number is this occuring in?

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • I don't remember for sure -- I think the previous one to 310, but one of the hanging things happened today (310) where the loading spinner is frozen for many seconds. So if it's the same thing, it's still happening.

  • Thanks for the update @AnotherAlex. After which action are you experiencing the app hanging with the loading spinner (In 310)?

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • Oh, I forgot to answer that. The spinner hanging is generally on starting the app, bit I haven't seen it today.

    In other news, editing recipes is failing enough to be frustrating. (Not complaining, I'm cool with testing and getting frustrated :) just info for you)

    Editing an ingredient, today it has kicked me out to the list of recipes without saving my hard work at least 4 times during one recipe, when:

    - I tapped done after editing units for an ingredient

    - I clicked into the name of the recipe to edit it

    - I tapped an ingredient to edit it.

    I feel for y'all. These are some tough issues to track down.

    Alex

  • Thanks Alex! The Recipe issue should be fixed in build 313 (3.0.5) - which you should be able to update to shortly - and the spinner hanging on the login screen should be fixed in this build as well. Let me know if it isn't!

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

Sign In or Register to comment.