Apple Health syncing works fine for nutrients, but does not work at all for Activity(w/ Apple Watch)

Hey guys,
I've had this issue for a while now and I've tried everything I found online to no avail. My problem isn't with the syncing between Cronometer and Apple Health data, which works fine on things like foods. What I have a problem with is that Cronometer does not seem to want to read data at all from Apple Health, which makes my calories lost due to workouts, walking around and lifting all be untracked as far as Cronometer is concerned.

Here's what I've tried:

a. I have disabled read/write privileges from Cronometer on Apple Health. I force quit Health, then restarted my phone. I re-enabled read/write privileges, nothing happens on the activity front on Cronometer.

b. I have pressed on "Disconnect Apple Health" then "Connect Apple Health", nothing happens on the activity front. Still no syncing.

c. I tried backfilling my data, with read/write privileges enabled, using the calendar icon next to the "Connect/Disconnect Apple Health" toggle, nothing happens even if I only choose a few days behind. The bar fills up blue, then it's filled. I go to my diary, no change on what calories I have burned.

d. I read here on these forums from a thread I found on Google that I should disable assumed activity levels (bmr and my tdee from sedentary/light activity/etc) and set it to none as to allow my Apple Watch data to sync and only use that instead of pre-determined calculations. Again, nothing synced.

e. My phone (iPhone 8+) was on iOS 12.1, nothing changed. I updated it to iOS 12.4, nothing changed. I then updated it to the latest iOS 13 Public Beta, and nothing has been fixed.

What gives?

Here is a short screen recording of what happens, if it helps:



  • Options

    i have the same issue

  • Options
    edited October 2019

    I’m considering changing from a Fitbit to Apple Watch 5. Your post is covering my concerns and research on how Apple Watch via Apple Health syncs with Cronometer, especially re: activity and calories burned. My Fitbit Charge 2 has been syncing perfectly since May 2018.

    Thanks for your detailed post on the syncing issue and what you tried to fix it. Pretty determined!

    BTW, I have my Crono app set to “none” on activity level as I am importing everything (but calories) from my Fitbit.

    Ill be watching for solutions. Thanks again.

  • Options

    I’ve had the same experience and have checked permissions. Just stopped working.

  • Options

    Seems the problem was on Apple’s side - re-paired watch and it started syncing again

Sign In or Register to comment.