List of foods in diary scrambled randomly



  • Hi again,

    The issue still persists. I've created a recent screenshot from the web app. The issue happens on both iOS and Web app platforms. Even after "organizing via timeline" the issue is the same.

    Please see here:

  • Hi Muska,

    Sorry this is still happening for you! Do you have a screenshot of the order before?
    Which item did you add to your diary when the scrambling happened? What other steps did you take? Did you select anything in the diary (have it highlighted) or click anywhere before you added the food that preceded the scramble?

    One thing that might explain the order in your screenshot: if you select 'sitting tasks, light effort' before you add a food, this would insert any items you entered after the selected exercise. This may have inserted the items logged 13:13 - 13:14 between 07:07 and 08:20.

    The key to figuring this one out is the steps you took that led up to the scramble!


    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • Hi @Karen_Cronometer ,

    This has been happening for months, and no order was ever made. That’s why I’ve opened this post!

    As soon as I added the lunch items at around 12.30 I’ve seen the discrepancy. This issue however apprears at any given time, all day every day!

    Nothing was highlighted, but Karen it wouldn’t make any difference if highlighting is present or not, since I’ve already stated: I pressed “organize by time” and it didn’t work!

    Also, the previous entries before the task were also groupped by hour. See the screenshot, doesn’t it look weird to you or the devs that certain groups of hours are thrown around?

    Please investigate.

  • Hi Muska1986,

    Any additional piece of information could be the key to helping us reproduce the problem, thanks for doing your best to describe what is going on. You never know what patterns or steps you might notice when it happens again. There are many AHA! moments in bug testing ;) We will keep digging to see if there is anything we can turn up.


    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • I have experienced similar behavior, although I am not sure it is the same thing. I am using the iPhone app and the web app (Opera browser on Windows 10), and the problem occurs only when adding items in the web app (although the misordering caused by the web app is reflected in the iPhone app).

    When I start the day, there are a few biometrics automatically imported from Garmin: Pulse, Sleep, and Weight. When I add food items, they are inserted between Sleep and Weight. If the page is reloaded, however, these items move to the top of the list, above all the biometrics, but new items continue to be inserted just above Weight.

    Copied-and-pasted items are inserted at the bottom of the list (and stay there), as are any items added from the iPhone app. And any items that I manually drag to the bottom stay there.

    There is nothing random about this behavior - it is entirely consistent and reproducible. This started happening at the same time as the introduction of the timestamp feature (which I don't have access to). I am in the UK, if that matters - maybe local time zone has something to do with it?

  • Thanks very much @HeadBeagle I appreciate your help!
    I have added this to the bug report.


    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • Honestly, this last update you made was even worse!!! Now my calories drop down to 2000 for the day when I add my weight!!! And I cannot use 0.5 of anything anymore, all shows 0kcal.

    Folks, I pay for this service, but it’s not really giving me any features at the moment that are worth it. Can you please address these massive problems at soonest?

    This is really getting annoying.

  • Hey I’ve found the reason to the last problem your devs have created! Why on bloody earth did they change full stops to commas? You destroy the system! I saved my weight with dots (since there’s no way to use anything else!!!!) and boom. The chart registered me with 0kg!!!!!

  • Hi Muska,

    Thanks for reporting this - we have found an issue in the way the app identifies your chosen language settings and your keyboard settings on your mobile device and have a fix coming! Our apologies for the error.


    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • update!

    Web app works in a funky way!

    I write comma (" , "), it doesn't register, writes down everything together (like, 835kg instead of 83,5)

    I write full stop (which is IGNORED in the iOS app), it accepts it? Change, desperately needed.


  • ASAP @Muska1986

    Apple does take time to review and implement app releases.

    In other good news, we are onto a fix for diary items being entered in an unexpected order - so expect that to come out soon as well!


    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • Good to hear, thanks!

  • My diary items are now being added in the expected order. Great. However, I noticed my Sleep and Pulse biometrics were not imported from Garmin today. Upon further inspection, I found them in yesterday's list, which now has two values (yesterday's and today's) for each biometric.

  • iOS and web app order still random.
    Weight on iOS still accepted as 0kg.

  • I may have spoken too soon. Items I added a few hours ago were inserted at the bottom of the list (and are still at the bottom), but new items are now inserted towards the top. Today's Pulse biometric has migrated from yesterday's list to today's, so that is now correct; however, there are now four different Sleep biometrics in yesterday's list (apparently one from yesterday and three from today).

  • Hi @HeadBeagle we have had a couple of reports of this issue and are looking into it. We would really appreciate it if you could send any further information about the garmin integration issue to Specifically, information about your device, if there is any other duplicated data from garmin, and screenshots if possible. Thanks for reporting this; We will let you know when the issue has been resolved!

    As always, any and all postings here are covered by our T&Cs:

  • Hi @HeadBeagle
    This bug has now been resolved. Please let me know if you run into the issue again. Thanks again for promptly reporting this!

    As always, any and all postings here are covered by our T&Cs:

  • The issue sill occurs. Please investigate and resolve at soonest.

    Also, when I try to put in my weight, it registers as 0kg in the iOS app.

  • edited November 2018

    Hi @Muska1986 ,

    Which issue are you still experiencing? To be clear, the issue which has been resolved is the duplicated Garmin data which @HeadBeagle reported.

    Just a reminder: please help us to keep this forum organized (As we do get quite a bit of activity). Please begin a new thread if the original thread title does not match the topic you wish to discuss.


    As always, any and all postings here are covered by our T&Cs:

  • @Hilary , for real?? This is my thread, what do you think, which issues??? 😂

    I’m honestly unsure if you ladies are trolling me or just really don’t care.



    How many times do I have to repeat myself?

    How many months do I have to struggle with this nonsense until you actually do something?

    Please leave the pc mumbo jumbo for somebody else. I need solutions, so I can use this app in peace! If you cannot solve such really challenging issues (like seriously, sorting order, and accepting “.” As before), let me know so I can find an app that works.

  • edited November 2018

    FYI - not sure what happened, but it seems the issue is solved on the web app.
    On the iOS however, when I continue input, the new additions come in the front, even though they are with the wrong time stamp.

    Could we have a sort-by-date feature working on iOS too?

  • I've noticed that this now generally works correctly on the web app (entries inserted at the bottom). However, once a Garmin activity is imported, the previous bad behavior returns, and new items are inserted near the top (initially below the biometrics and just above the activity - but they move above the biometrics after a refresh).

  • edited April 2019

    do you have any clues how to correct this? It happens with my iPhone X and Mac. I haven't tried to monitor the timestamp question nor specific order of the randomizations.

  • Here it is 5 years later and this issue still persists? I know I add in my blood glucose readings 1 hr after breakfast and 2 hours after breakfast under the breakfast category and it invariably puts them at the top of the breakfast listing and then I have to drag them to the bottom or go up and click the 3 dots in the top right corner and select Sort all Entries by Time. Works fine when I add things on the web, but 99% of the time I'm entering on my phone

Sign In or Register to comment.