Iodine?

I don't see iodine on the calculated nutrient list. Am I missing it somewhere?

Best Answer

  • Accepted Answer

    If you go to your account settings, under minerals there is an option to enable iodine. Enabling it gives the warning "our database currently has very sparse data for iodine" but you can still enable it.

    #moredotsthanadalmatian

Answers

Sign In or Register to comment.