[Bug]: Connect Apple Healthkit

When clicking "Connect Apple HealthKit" in the Settings tab the iOS app becomes completely unresponsive and locks up (unable to scroll or tap anything else) for a good 8-10 seconds, and then there is no noticeable feedback... but any of the scrolling and tapping you did while the app was locked up affects the settings screen; I accidentally toggled "show calories summary" while trying to get the screen to respond again.

I did already have HealthKit data pulling into Cronometer before installing the beta app, so I'm not sure if this is actually a new bug, or simply related to the fact that I already had turned on HealthKit integration previously... either way, the lack of feedback telling me I've already connected HealthKit and the fact that the app locks up make this feel buggy.

«13

Comments

  • edited February 14

    I can also reproduce this bug. I get the timeout as well and then the screen is responsive again after it processes all the touch events it received during the timeout.

    I also already have HealthKit data pulling into Cronometer before installing the beta.

    I did notice that the "Active Energy" calories in the health app do not match what is showing in Cronometer. I don't know if they are supposed to match or if they matched before the beta.

    My active energy calories burned comes from my Apple Watch.

    iOS version: 12.1.3
    iPhone 10S MAX

    Thanks!

    Cronometer Active Energy:

    Apple Health App Active Energy:

  • I ended up disabling Cronometer's Read/Write priveleges in the Health app, and then re-enabling them. That seems to have corrected the locking up of the app issue. When clicking the "Connect Apple HealthKit" button it now toggles back and forth between that and "Disconnect Apple HealthKit."

    However (and I'm not sure if this should be filed under its own bug report), as PresenceGuy noted: there is some funky business happening with HealthKit data.

    I'm guessing that I have (possibly?) a more complicated fitness/life tracker set-up than a typical user: I wear both an Apple Watch and an Oura ring, and recently Peloton released a software update that writes ride information to the Health app and I have one of those as well.

    I've had the Apple Watch for a few months and it had been working great with Cronometer (prior to the beta), subtracting my Active Energy and workouts to arrive at my net calories and adjust my macros for the day.

    Now with my Apple Watch, Oura ring and Peloton all writing some overlapping data, and the installation of the beta app, I'm getting some crossed wires in my net calories and macros:

    • In some cases activity is subtracted, in others it's added (and some of the entires don't specify where the data came from).
    • In some cases two workouts are clearly the same workout, and even more strange: one subtracts from my net calories and one adds calories back...
    • For the screenshot from today, February 13, the app did not pull in my active energy at all, only the activity I logged with the Apple Watch activity app.
    • In the most extreme case, on the screenshot from February 12 it's pulling in activity data from the Aura ring, and the Oura ring is getting its data from both its internal movement tracking and activity data from HealthKit.

    I'm guessing this is at least partly my fault for having several sources writing similar, but not always exactly the same data.



  • I can also confirm what wdavidow says above:

    I ended up disabling Cronometer's Read/Write priveleges in the Health app, and then re-enabling them. That seems to have corrected the locking up of the app issue. When clicking the "Connect Apple HealthKit" button it now toggles back and forth between that and "Disconnect Apple HealthKit."

    This worked for me.

    Also, I have my activity level in Cronometer set to "None".

    I also have a Oura ring, but I have "Import Activity" turned off. I get my activity stats from Apple Health - Primarily the Apple workout app and FitBod.

  • Thanks guys. This feature is still in progress to a certain extent, so look for this to work better in the next beta build or two as we work out the kinks.

    Spencer D.
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • Further info this morning - My biometric data from Apple Health did not successfully sync into Cronometer.

    I tried several things:

    • Toggling "Connect Apple Healthkit"
    • Uninstall and reinstall Cronometer beta

    I uninstalled the beta temporarily to install the app store version to sync things over this morning.

    When I toggled the "Sync With Apple Health" button on with the App Store version, I got the Apple Healthkit permissions dialog like I expected to approve Cronometer access.

    I do not get the permissions dialog when I first install the beta Cronometer and toggle on "Connect Apple Healthkit" and it times out/hangs.

    App Store Version Sync Button:

    Apple Healthkit Permissions Dialog:

  • Im also having Apple Healthkit issues. When updating to the beta build Apple health Kit is not connected in the cronometer app. When I launch Healthkit under sources cronometer the toggles are all green, but at the top "Turn All Categories On". Once I select that option and go into cronometer to select Connect Apple Healthkit the app completely locks up. After some time it will relaunch but the Diary page is blank. As soon as I turn off permissions in Apple Healthkit the App launches and Diary page loads.

    I also attempted with a clean install of the Beta build and the issue persists.

    Currently I'm unable to use the beta build v3 (48) with Healthkit permissions on.

  • Mine isn’t locking up anymore, but it’s not writing to Apple health at all. Going to try a clean install.

  • It appears that with this afternoon's release 3.0 (278) that all of the issues I've noted around importing of health data in this thread are resolved. I did have to delete the messed up days and let the app re-import my data, but it did import correctly once I did that.

    I have not experienced the initial thread-starting bug where the app locks up when tapping "Connect Apple HealthKit" again either.

  • edited February 15

    Actually, maybe one question around Apple Health’s “Active Energy” category: as far as I can tell that number is comprised of both exercise and general movement throughout the Apple Watch wearer’s day. It was previously included in the imported data and had an affect on the day’s calorie count. Is it intentional that only official workouts (walking, running, lifting weights, biking, etc...) are included in considering net calorie count now, or is that something that will be making its way back into the picture? Fow what it’s worth, I don’t know if non-exercise energy expenditure _should_ contribute towards net calories or not, but this was just something I am curious about.

  • With iOS beta version 3.0 (278) I can still recreate the app freeze/hang up bug.

    Here's the steps I followed:

    1) Uninstall the 3.0 (278) beta Cronometer app
    2) Reinstall from test flight.
    3) Open Cronometer beta and login.
    4) Open settings and tap "Connect Apple Healthkit" - App Hangs As Before

    I then looked at the Cronometer permissions with the Apple Health app and noticed all categories were off (see below). I enabled all categories, reopened Cronometer and was able to toggle "Connect Apple Healthkit" to on (showing "Disconnect Apple Healthkit".

    I then added a food item to the diary and Apple Health nutrition data was updated correctly.

    I will update in the morning after more testing.

    Apple Health Dialog:

  • With iOS beta version 3.0 (278), my biometric data from Apple Healthkit does not yet sync.

    Each morning, I sync the following:

    Oura - Sleep, Pulse
    Withings - Weight, Body Fat
    Apple Healthkit - Pulse, Systolic and Diastolic Blood Pressure, Weight, Body Fat

    I would like to turn everything off and have everything sync from Apple Healthkit at some point.

    To get the biometrics to sync, I followed the same scenario I did yesterday.
    I uninstalled the beta temporarily, and installed the app store gold version, enabled Apple Healthkit Syncing, allowed it to sync and reinstalled the beta.

    • Thanks!
  • edited February 15

    It seems as though HealthKit activity/workouts are still affecting Net Calories in the wrong direction (adding to, instead of removing from). In the screenshot you can see that my net calories consumed INCREASED from my workout, instead of decreasing). This also appears to affect the Calorie Deficit/Balance panel to the left of Macronutrient Targets

  • Feb 21 update.

    The most recent update to the beta is installed. Today I recorded my glucose, ketones, and weight. I guess o forgot to relink to Apple health when I updated, so I did it just now. The glucose reading, went over wrong. My body fat imported wrong.


  • edited February 22

    Apple Health testing with the latest iOS beta - 3.0 (280):

    To test the below, I uninstalled the beta version and reinstalled the app store gold version. I then enabled Apple Health settings and verified that Cronometer was reading and writing to Apple Health. I then installed the newest beta version 3.0 (280) on top of the app store version.

    1) I still get the app freeze / timeout in Cronometer when tapping "Connect Apple Health" in settings. The new Apple Health Permissions dialog pops up after the timeout. I have to manually enable Cronometer with "Turn All Categories On" in the Apple Health app before I can tap the "Connect Apple Health" text in settings.

    This seems like a regression to me, the app store version opens the Apple Health Permissions Screen in Apple Health for the user to select "Allow" rather than having to depend on the user being able to manually enable Cronometer in the Apple Health app.

    Am I mistaken and barking up the wrong tree? (Thanks)

    2) All entries written to Apple Health have 12:00:00 AM as the date entry

    3) I have duplicate entries imported from Apple Health with "(healthkit)" instead of "(Apple Health)".

    New Apple Health Permissions Dialog:

    Entries with incorrect time:

    Duplicate entries:

  • A few more comments from the next morning with iOS beta 3.0 (280):

    Good news - The items imported with the beta version. I didn't have to switch back to the production app store version.

    Here's the issues I noticed this morning:

    1) "Active Energy" is misspelled "Acitve Energy"

    2) The biometrics imported from Apple Health all have the correct "Apple Health" source on the iOS beta app, but are labeled as "healthkit" source on the web version of Cronometer

    Note that the source for Active Energy is correctly "Apple Health" on both platforms.
    The other items are all third party integrations writing data into Apple Health.

    Also, Active Energy is importing as exercise data, while the others are importing as biometric data. This is correct obviously - just pointing out that the bug may be with the iOS Beta app importing biometric data entries.

    3) An enhancement suggestion - If Apple Healthkit exposes the "Source" field to applications as seen below in the third party screenshot, it would be great if Cronometer used that as the Source instead of a generic "Apple Health" source label.

    Screenshot From Web Browser (Windows 10, Chrome Version 72.0.3626.109):

    Screenshot From iOS Beta 3.0 (280)

    Third Party Healthkit Entry:

  • One additional observation on top of what @PresenceGuy just noted:

    My Oura ring data is not always being imported. Yesterday toggling the data it imports (under “Connect Devices”) was enough to get it to pull in data, but today that did not do it. Neither did completely un-linking and re-linking my Oura account.

  • I also have a Oura ring set to import like @wdavidow. My Oura ring data has imported successfully this week, but it takes a indeterminate amount of time before I see it imported.

    One other thing I just noticed with the Oura ring data import is that it does not have a time entry. All the rest of my biometric imported data has a time displayed.

    Import snapshot:

  • Second morning with iOS beta 3.0 (280):

    BTW - Thanks again for a great app! Use it multiple times a day. Can't wait to see what you guys are planning for in the future...

    I am using this post as a kind of summary of what I am seeing with the current iOS beta version 3.0 (280) regarding Apple Health biometric data integration.

    Just to reiterate, I import the following each morning. I have attached my Cronometer Healthkit Read Permissions Dialog below.

    • Sleep and Pulse data (Oura Ring direct import and Healthkit)
    • Weight and Body Fat (Withings direct import and Healthkit)
    • Blood Pressure (Omron via Healthkit)

    I also import exercise data via Apple Watch 4 and Oura Ring but I am focusing on biometrics for this post.

    My morning routine for most days with Cronometer:

    • Open web version and plan meals for the day
    • Open iphone version to sync apple health data
    • Refresh web version and continue my daily plan.

    Observations:

    • Oura ring data from direct import was immediately available when I opened the web version this morning. This was about 5 minutes after I synced my ring with my phone.

    • "Active Energy" is misspelled "Acitve Energy"

    • The biometrics imported from Apple Health all have the correct "Apple Health" source on the iOS beta app, but are labeled as "healthkit" source on the web version of Cronometer

    • Oura sleep hours did not import from Apple Healthkit (if it's supposed to)

    • Oura ring data from direct import does not have a time entry.

    • Withings weight and body fat did not import from Apple Healthkit (if it's supposed to)

    Please see the following screenshots below for context:

    • Web Version screenshot before opening / syncing iOS App
    • iOS App screenshot
    • Web Version screenshot after opening / syncing iOS App

    Device Info

    • Windows 10, Chrome version 72.0.3626.109
    • iOS version: 12.1.3
    • iPhone 10S MAX

    Web Version before opening / syncing iOS App:

    iOS App:

    Web Version after opening / syncing iOS App:

    Cronometer Apple Healthkit Read Permissions:

    Cronometer Web Version Device Settings:

  • Hey guys, Just want to say thanks for all the bug reports on this. It is helping us calibrate how to fix the issues we are seeing.

    You guys rock!

    Spencer D.
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • Just downloaded the fresh beta release this morning, v3.0 (284)

    A couple observations around health data:

    Active energy is still misspelled - “acitve energy.”

    My pulse reading was imported twice from HealthKit (under two different headings).

    I had synced my Oura ring and opened Cronometer prior to installing the new version, which gave me Oura data, active energy and pulse reading in Cronometer. When opening the app after installing this morning’s new beta release there were suddenly two “acitve energy” entries with different values (one with “healthkit” and the other with “Apple Health” as its source). I deleted both in the web interface and then closed and re-opened the iOS app and it re-imported just the single entry.

    Lastly, the time stamps on all Apple Health entries are still off - I didn’t sync anything at 12:03am.


  • In testing v3.0 (284), I also am noticing a buggy Pulse entry imported from Apple Healthkit. It updated at some point after I started exercising and the value is obviously from the start of the time period when I was exercising..

    Normally, the value tracks closer to the Oura Ring directly imported value.

    Also, I am still seeing "Acitve Energy" as well.

  • I just installed v3.0 (285). It has fixed the misspelling of Active Energy.

    I will have to wait till I go to the gym tomorrow to test the Pulse item above.

  • @PresenceGuy

    Currently, for any data set we get from Apple health, we take all the data points and average them into a single entry. This makes sense for some things, but pulse may not be one of them. At the same time, we don't want to import every single individual entry and fill up your diary with tons of data, cluttering it up.

    What I am curious about is how you were using it on the current build (i.e. before switching to beta). Were you getting different readings? or were they more in line with what you expected to see?

    Ultimately we will have to address every importable piece of data individually, and that is not something we will target for this initial release.

    Cheers,

    Spencer

    Spencer D.
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • edited March 1

    @SpencerD,

    I know you were addressing @PresenceGuy in your last message, but my two cents on this matter is:

    I've typically had, and expected, the pulse entry to be the first pulse reading that HealthKit receives that day, typically when I put on my Apple Watch first thing in the morning.

    If possible, I think it would be more useful to have multiple entries for pulse that maybe show low/high values for the day, rather than some arbitrary single reference point.

    Prior to the beta it was behaving as I noted in my initial expectations, but in the recent beta releases it appears to be grabbing pulse rate pretty randomly. First it will grab it "as expected" early in the morning after strapping on my watch, but some point in time during the day it will update that value to something higher, which leads me to believe the app is updating pulse during some form of physical exertion.

  • I think it would nice to be able to choose few times to get the pulse reading. I wear my watch to sleep so one during sleeping then after waking up (or just some interval).

  • @SpencerD @wdavidow @JGLongIsland

    Sorry, this turned into a book...

    Before the beta, I believe the Apple Healthkit Pulse entry would be from the first Oura ring entry from 12am - 1am. I don't believe the Pulse entry was updated later during the day.

    With beta 3.0 (285) this morning, the Apple Healthkit Pulse reading was the same as pre beta. However, once I started exercising, the Apple Healthkit Pulse entry was obviously higher.

    What I think is happening is the beta is updating the Pulse entry as Apple Health updates the entry in Apple Health throughout the day. It's not apparent unless there is exercise which causes the the average heart rate to be higher.

    What I would love to see :smile:

    Apple Healthkit updates average "Resting Heart Rate" and "Walking Heartrate" heart measurements throughout each day as well as a workout record for each workout. Each workout record contains many details of the workout including start/end time and min/man/average heart rate.

    Note, these may only be available with Apple Watch, so this may not be useful for iOS users without an Apple Watch.

    My humble opinions of what I think would be useful:

    • Pulse - Not sure what to do here. I'm not currently deriving any useful metrics from Healthkit average pulse because it can vary so widely if exercise is recorded.

    • An biometric entry labeled "Resting Heart Rate Average (Apple Healthkit) imported/updated from Apple Healthkit throughout the day. The time recorded for the entry would be when Cronometer last synced the entry from Apple Healthkit.

    • An biometric entry for each workout with the average heart rate. for example "4:42pm Workout Heart Rate Average 122 bpm"

    The above entries would allow future plots/graphs of useful heart rate data if Cronometer actually wanted to go deeper into this area.

    Thanks for reading my book. :smiley:

  • Whenever I go to enable Apple HealthKit after a new install (just installed 286), and then go to the Food Diary, the screen locks up and I can't do anything. Then the app closes out and when I go back in it never loads. Is HealthKit just not supported in the beta? I'm a new tester.

  • The latest beta version is working with Apple Healthkit for me.

    Can you check in the Apple Health App and make sure that Cronometer is allowed to read and write data?

    It's under the Sources tab at the bottom.

  • If all the categories are on and I choose connect HealthKit the app just doesn’t work. It’s a brick as soon as you click on the diary.

    Worh that disconnected it works. I’ll delete and go back to the old release until the next beta comes out.

  • @JGLongIsland

    Does it start responding to touch events after a period of time like 30 seconds or 1 minute? Can you scroll the diary?

    For me, when I would tap "Connect Apple Health" the app would be non-responsive for about 30 seconds and then it would respond. But, that was 3-4 beta versions back.

Sign In or Register to comment.