[Bug]: Connect Apple Healthkit

13

Comments

  • edited April 2019

    Very latest 3.0 (301)I connected and succeeded in importing from Apple Health.

    Later while inputting my dinner it popped up the attached error and logged me out! Fortunately I have a prodigious memory for quantities in grams so I was able to recover from the trauma and resume entering my dinner.

    seriously though, there was nothing wrong with my wi-fi signal as stated in the error.


    Maria H
    My story: jumpovertherattlesnake.com/

  • Got another Apple Health issue with build 301. (The screenshot is yesterday's but I got the same today.)


  • edited April 2019

    @VegasTortoise thats for reporting this - our developers are working on fix for this. The next time this happens, would you mind please force closing and restarting your app immediately, and shoot us a message here when this occurs, so that we can look into what is happening a little closer.

    @AnotherAlex we have changed the error message that you are receiving here slightly in order to get better information about what the root of the issue is. The next time you receive this error would you mind please posting another screenshot of the updated error, as well as force closing and restarting the app.

    Thanks for all the feedback, both of you! Your help is getting us closer and closer to a public release!

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • okay, I'll watch for it.

  • I will do that @Hilary also latest IOS update 12.2 just came out

    Maria H
    My story: jumpovertherattlesnake.com/

  • edited April 2019

    Okay, just happened again, I closed and restarted.

    i did upgrade IOS to 12.2

    Maria H
    My story: jumpovertherattlesnake.com/

  • Forgot to add, it did import data from Apple Health, then the error. When I open Cronometer again the Apple HealthKit setting is disconnected

    Maria H
    My story: jumpovertherattlesnake.com/

  • All versions of the app (Beta&noneBeta) are not importing data from health kit. I have tried all the usual connects & disconnects in both Cronometer and Healthkit. Deleted the app and sign in and out with no success. This happened to me overnight when the iPhone updated to the new operating system.

    Anyone have any advice to get Healthkit to sync again. Either in Cronometer or Beta Cronometer?

  • Thanks for letting us know @beerad and @AnotherAlex . Can you confirm if, on the settings tab of your Cronometer app it indicated that Apple health is connected? (If it is technically connected but not importing, you will see "disconnect Apple Health" listed)
    It could be that the update/restart of your phone lost the connection and all you need to do, may be to re-link Apple health via Cronometer as you originally did.

    Hilary
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • You correct, "disconnect apple health kit". When I try to reconnect it just by pressing "disconnect Apple health kit" it changes to connect to apple health kit. Pressing just restarts the process.

  • Same. I tried disconnecting and reconnecting and it didn't work.

  • Just went though again to make sure nothing had changed. I have zero data from Apple Health in my diary for yesterday or today.

  • @beerad @AnotherAlex to help resolve this issue, could you please let us know the build and version number you have. Cheers

  • 3.0.7 (318)

    By the way, every time I get asked this question a minor annoyance about the app gets a little more annoying. The forum kicks me out every time I so much as switch apps for 30 seconds to check something (like the build number). Is there anything that can be done about this?

  • Thanks for the quick reply @AnotherAlex , I will ask @Hilary to log a bug for the forum booting you out, when's she's back next week. Version 3.0.8 is available in the app store, could you please let us know if the problem persists after upgrading. Thanks for your patience.

  • When will 3.0.8 be available on TestFlight (or is the beta over)?

  • On version v3.0.8 (b319-IF)

  • @beerad and @AnotherAlex if possible, could you please send a screen shot to [email protected] of the entries in the AppleHealth app for a day that isn't importing. Thanks

  • Could you clarify what screenshots you would like from AppleHealth. Activity, Workouts, Active Energy, or all. Thanks

  • @beerad, sorry for the lack of detail, if you could please email [email protected] shots of the following tabs in AppleHealth for a day that doesn't import:

    • Today -> Active Energy, Exercise Minutes & Workouts
    • Health Data -> Activity -> Active Energy, Exercise Minutes & Workouts
    • Health Data -> Workouts -> Show All Data ->
      Much appreciated, thank you.
  • I sent over the screen captures.
    Thanks. Brad

  • Okay just noticed after sending the email sync is working again...
    The back fill option still will not fill in two missing days, But as long as it continues to work I'm happy.

    Will update with a post tomorrow.

  • I think we're good.

  • The same issue continues. Not sure way the app updated randomly late yesterday. I do recall it happened once the app froze and I had to force restart the app.

    Under the settings tap in Cronometer it appears to be trying but no data actually imports from Apple Healthkit.

  • i am on the latest version and it’s still takes too long to get HealthKit data. There should be a progress indicator or a fetch now command. If I leave it open for a few minutes it usually works. Version2.3.5 was much better.

  • Thanks for the tip @JGLongIsland, Sync from health kit can be achieved if I leave Cronometer open and active for several minutes. At times I have to force quit the app and try again, but eventually Cronometer syncs with Healthkit.

    A work around be not a final solution. Earlier version of Cronometer sync was instant.

  • I've found that either quitting the app (as stated by others) or using the top bar and going ahead or back a day, and then coming back to the current day will usually do it.

  • @beerad @wdavidow @AnotherAlex @JGLongIsland apologies for time is taking to fully resolve this issue, it is being actively worked on, and will provide an update, once we have a release to fix it.

  • It still take way too long for Apple Health info to update. Sometimes as much as a minute. There needs to be a progress indicator and a gesture or button to update the screen.

Sign In or Register to comment.