Cronometer food info is not transferring to Fitbit

I have synced my Fitbit app with my Cronometer app, and Cronometer is pulling all of my Fitbit data with no problem, but it's not writing my nutrition data to Fitbit. I have had this app for years and used it many times and had no problem like this before. I even tried unlinking and relinking the apps, but no success. I really like the Cronometer app for food logging, as it's far superior than any other app I've used, but I'm going to have to stop using it if I can't convince it to write the info to Fitbit.


  • I linked fit bit and crono and they transfer informeation as expected so at least we know it can work.

  • It can, it's just not at the moment. Thought it might be a glitch with a recent update. I wanted to see if anyone else is having the same problem, or it's just me.

  • I'm having the same issue

  • Seems to be working today though

  • Same problem. Syncing all but food.

  • thanks for reporting this! Please follow the steps in the Cronometer device troubleshooting guidlines found here:
    If this does not resolve your problem, please contact [email protected] with more details about the issue including:
    1. Does this happen on mobile or web?
    2. If it is occuring on the mobile app, what version of Cronometer are you using? (Found at the bottom of the login page or on the app store)
    3. If occuring on the mobile app are you using iOS or Android
    4. If it is occuring on the website have you tried clearing your cache

    As always, any and all postings here are covered by our T&Cs:

  • If or when the syncing to fitBit works doies it just log the daily calorie amount, or the the amount of calories, carbs, fat, and protein by meal/time? (I need the nutrient intake amount and time to match to insulin intake time (in ManageBGL).)

  • I just downloaded the cronometer app and followed instructions to link to my fitbit, the info on my fitibit was transferred to cronometer with no problem however the food log has not exported to my fitbit app. It's been about 4 hours since my last entry, what should I do? I tried the unlinking and re-linking, revoking access, etc. nothing is happening. I'm working with Android apps; both apps latest version downloaded.

  • Only the total calories are exported to your Fitbit account.

    The food logs and times you logged them aren't included.

    @IvieV if you aren't seeing your calories coming through to fitbit shoot us an email at [email protected] and we will help you with some more in-depth troubleshooting.


    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • I look for ways to import data from other apps into crono only because crono has the best facility for doing that and there is some customized reporting. In the best of all worlds there would be apps specialized for aggregating consumer health and fitness data. The app developers would all connect to that one app one time. If this existed there could be gigantic observational surveys to may be improve clarity on health issues that are confounded by many variables.

  • It's 2021, and I've been having this same problem for as long as I've used Cronometer. I've synced everything properly, checked ALL boxes, unsynced and re-synced, etc. to no avail. I've pretty much given up on it. It shouldn't be this difficult. Other calorie tracking apps I've used worked flawlessly with Fitbit without the constant need to troubleshoot.

  • I agree with @SimplyCidalia . It is so difficult to solve this issue?!? Its seems that this issue is very old. I also did all the steps os unlink, relink, revoke access etc and still nothing.

  • I am now in this camp as well. I just started using Cronometer. Initially, the free account I set up imported into Fitbit (for my nutrition). Then I upgraded to Gold and now it does not work. That part might be coincidence, however, because they ALSO updated the app twice within that same week. It worked for 4 days, and now nothing. And I, too, have done literally everything I can. Uninstall, reinstall, clear cache, log out, log in, reboot, relink. It is very frustrating. I am in and out of the fitbit app so I find this integration helpful...when it's there/working.

  • It's several years later and I'm also having this problem. Did anyone ever get this resolved?

Sign In or Register to comment.