Problem syncing calorie data to Fitbit

I recently made the jump from MFP and was playing around getting all my integrations setup and while getting data to feed from Fitbit into Cronometer was simple, just connect the apps and allow access then my Fitbit data feeds into Cronometer without issue, seeing my calories from Cronometer in Fitbit not so much. After revoking access and resetting it up multiple times I came across the article below:


While this outlined the steps I had already taken in regards to Fitbit with no success, I noticed that it said it pulls the data for the device software. I went into my apps settings (I am using a Samsung Galaxy S20 btw) and checked both Fitbit and Cronometer and checked the permissions and they had the permissions that were authorized when I setup the app like body sensors, camera, Fitbit had location and phone, but both had device storage denied, so I updated both to allow access to device storage and everything worked. When first setting up either app I was never prompted to grant access to device storage. I don't know if that is a bug or if there was an issue local to my device, but I thought I'd share my findings incase anyone else is facing the same issue.


  • Options

    Thanks so much for posting this! I'll pass this along to the development team to see if there is something we can do to make this process more seamless. Thanks so much for taking the time to troubleshoot that and let the community know!

    Karen Stark
    As always, any and all postings here are covered by our T&Cs:

  • Options

    I also am experiencing this problem. However, AlaskaJedi's solution did not work for me. I've tried unlinking and linking again, revoking and then reinstating access, and enabling all permissions on both apps. No success! For some reason, Fitbit has decided to ignore Cronometer completely. This started today.

Sign In or Register to comment.