HELP after months of posting here glucose readings are still flipping to mmo/L

edited July 29 in Help

Each and every time that I enter a glucose reading the wrong sunits are displayed. I change them to mg/dl. Then the next time I use it ..it flips back to mmo/L again. This has been going on for months. In the past you have had me "LOCK" the setting in somewhere that I can not now find. I hasn't worked -- it seems as this keeps happening. For a year now if I am not mistaken.

Any word on what is going on?

Joe Tittiger
Seymour MO
joe ATT Tittiger DOTT com

Comments

  • Wow, I can't believe nobody has fixed this yet. I'm having the same problem. There needs to be something in the settings that allows you to choose a default unit for these things. I just had to go back through an entire month and fix the blood glucose units! Conometer? Hello? Anybody home?

  • There was such a setting to the best of my recollection. I think is was removed and it never worked right when it was there. I agree I think that one of the worse things you can do is to copy the MicroShite model and just keep turning out data destroying code regardless whether or not it actually works.

    If they don't change their priorities I think there is a real possibility of this biting them in the ass. The only reason I stick around is perhaps some misguided loyalty as I do want to see this company succeed.

    Glad that I am not alone in this observation.

    Joe Tittiger
    Seymour MO
    joe ATT Tittiger DOTT com

  • I know this is very much not the solution you want, and I don't work for chronometer, but a potential solution is to just let the stupid software program remain in mmol/L and enter the data as such. If your glucometer doesn't give you these units, you can convert by multiplying/dividing by 18.

    Example: if your blood glucose is 100mg/dL, it's 5.55mmol/L because 100/18 is 5.5. Again, not a solution, but it'll keep you from screwing up months of work by using inappropriate units.

  • The better solution might be to remember not to use the shortcut entry (on the left) as I think that the long method at the top works correctly. You would think that CM wold either disabled or fix the darn problem though.... someone needs to put on their thinking cap and quit screwing the paying customers.

    Joe Tittiger
    Seymour MO
    joe ATT Tittiger DOTT com

Sign In or Register to comment.