App crashing at start

Hello,

Since about 15 minutes ago the app has been crashing at start. I open it and it shuts down immediately. I've tried restarting the phone and it doesn't fix it.

My phone is a Xiaomi Mi 9T Pro, Android 10, MIUI 12.0.5.

Thank you.

Comments

  • Hi Spica,

    Thanks for reporting this!

    Do you have any apps or devices connected to your Cronometer account, like Samsung Health, Google Fit, etc.?

    Could you please try uninstalling and reinstalling the Cronometer app on your phone?

    Karen Stark
    cronometer.com
    As always, any and all postings here are covered by our T&Cs:
    https://forums.cronometer.com/discussion/27/governing-terms-and-disclaimer

  • Hi Karen,

    I have Google Fit connected. I tried reinstalling the app and it fixed the issue. Thank you!

  • edited February 6

    Hello,

    I have the same issue since this morning. I have Google Fit connected to the Cronometer account.
    I have tried to reconnect Google Fit, uninstall and reinstall both apps, delete the data from Google Fit.... nothing worked.
    When Google Fit is not connected, Cronometer starts and works normally.

    Everything started when I tried to delete a biometric that was imported through Google Fit. Up until that moment, everything was working very well.

    My phone is a Xiaomi Redmi Note 9 Pro, Android 11, MIUI 12.5.4.

    Update:
    Something that may be helpful. It seems the problem occurs when browsing the current day. When going through the calendar to the previous days (or future ones), the app is not crashing. When I go to the current day, it immediately crashes. I cannot confirm the Google Fit integration works normally however, since the Google Fit data has been deleted.

    Thank you.

  • As posted here: https://forums.cronometer.com/discussion/4687/syncing-with-google-fit-keeps-crashing-cronometer

    This is a cronometer issue. Here is my bug report.

    I use:

    Zepp 6.9.7
    Google Fit 2.81.1.arm64-v8a.release
    cronometer 3.21.3

    on Android 11 (4.9.227-perf+ kernel)

    This is a cronometer issue, because here is what happened:

    Installed Zepp and synced with Amazfit GTS 3 watch and Amazfit scale. Works fine. Because cronometer does not offer a Zepp integration, I use Google Fit to bridge the gap. Google Fit transmits the data to cronometer then. (This works with all other apps as well, e.g. Daily Yoga or Headspace. No problems whatsoever.)

    Until I deleted a few redundant entries from my weigh-ins (within Zepp), I had no issues. I both deleted an entry in Zepp and later one in cronometer (on the phone). After doing the latter, cronometer crashed and would not come back. (As in start up, show the diary page for a fraction of a second and die without report.)

    So I deleted app data in Android settings (includes cache and login), logged in again and started over. I did this a few times as well as rebooting the phone and installing all three apps from scratch after deleting the app directories. (It's not necessary to do that! You just have to delete the app storage, then you can start cronometer again.) I restarted the cronometer app and logged in. But as soon as I click on the integration, cronometer would crash again. This would only happen with the Google account synced to Fit, not a dummy account I used for testing (with no data and no Fit integration.) As soon as I integrated the dummy with the same Fit data, cronometer would crash again.

    I "resolved" this issue by creating a new cronometer account.

    I was able to sync cronometer with Fit again and backfill the last days. My other data (custom foods, kcal and so on) is gone. So, now I have literally the exact same activity data as before in my cronometer with no issues. All I did is create a new account. The data has not changed, Google Fit has not changed, Zepp has not changed. It's all the same. The only parameter I changed was that obviously corrupt cronometer account.

    This is really sad. I am a developer myself. Please fix this.

Sign In or Register to comment.